public enum { java ee,ubuntu, gnu/linux,musique, and something completely different... }

Aller au contenu | Aller au menu | Aller à la recherche

m-audio audiophile24/96 et lucid lynx

Mon PC fraichement installé avec le koala, me voila dans l'idée de faire fonctionner ma carte son m-audio audiophile 24/96.Ce qui semblait fonctionner sans problème sous Jaunty ne fonctionnait pas du tout avec karmic :-( J'ai eu précédemment un gros coup de bol. Après un test de son, je n'avais aucune carte son détectée via aplay,pulse audio ou n'importe quel outil.

J'ai d'abord cru à un problème d'alsa ou lié à la version de pulseaudio . J'ai donc mis à jour mon OS favori vers la version alpha2 de lucid lynx et la toujours le même problème (j'en ai pas eu d'autres, c'était déjà ça ...)

Voici ce que j'ai effectué comme manipulation

warning.png ATTENTION : je suis passé à une version alpha et je modifie un des fichiers de configuration. Si vous reproduisez cette manipulation, ca peut provoquer chez vous une grosse instabilité de votre système.

ICE1712: probe of 0000:04:00.0 failed with error -5
ICE1712 0000:04:00.0: PCI INT A disabled

Pour cette erreur, la seule manipulation que j'ai trouvé à faire était de .... changer la carte son de slot PCI. Je sais c'est plutôt brutal, mais ca fonctionne.

Après redémarrage, ma carte était reconnue par le système mais ne produisait pas de son.


$ dmesg | grep -i ice1712
[   13.181247] ICE1712 0000:04:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   13.181272] ice1712: Using board model M Audio Audiophile 24/96

Pulseaudio ne connaissait pas les sorties analogiques. J'ai donc suivi ce post et ajouté les lignes suivantes dans la section PCM.FRONT du fichier /usr/share/alsa/cards/ICE1712.conf

CE1712.pcm.front.0 {
	@args [ CARD ]
	@args.CARD {
		type string
	}
	type route
	ttable.0.0 1
	ttable.1.1 1
	slave.pcm {
		type hw
		card $CARD
	}
        slave.format S32_LE
        slave.channels 10 
}	

Après un redémarrage, il ne reste plus qu'à sélectionner la bonne sortie ( analogique dans mon cas) :)

selectionsortieanalogique.png

Bon, j'espère que cette manipulation pourra servir à d'autres personnes. Franchement, je ne pense qu'il soit nécessaire de passer sous lucid lynx.Je n'ai pas testé la dernière configuration sous Karmic. Si il y en a qui sont dans le même cas, n'hésitez pas à l'indiquer dans les commentaires :)

Commentaires

1. Le jeudi, février 4 2010, 23:51 par djib

Il y a le même problème sur Fedora 11 (et probablement 12). Je ne pensais pas que ça concernait d'autres distributions. Il serait peut-être intéressant de faire un rapport de bogue à Alsa…

2. Le vendredi, février 5 2010, 15:14 par pluviotor

Pulseaudio me fait un peu vomir pour des applis de sons particulières.
Pulseaudio c'est balaise mais plutôt versatile...
Enfin un billet qui vaut le coup d'oeil sur le planet . Merci à toi.
Car en ce moment c'est plutôt "cote west" ou "amour puissance et gloire" enfin bon... Linux is Ubuntu or Ubuntu is Linux?
J'aime les remontées d'un gars qu'a mis les mains dans le cambouis.

3. Le samedi, février 6 2010, 11:21 par Refuznik

Merci, j'avais eu le problème sur F12 et arch (reconnue, sélectionnable mais aucune sortie son valable), bon j'ai été plus radicale en novembre, je suis repassé sur le chipset audio de la cm.

4. Le samedi, février 6 2010, 12:37 par littlewing

@Refuznik: ca m'aurait fait un peu chier de ne pas utiliser une carte son achetée 75€ et basculer sur la carte son embarquée dans la carte mère... :D

5. Le mercredi, mai 5 2010, 16:43 par littlewing

Salut,

quel est ton pb ?

qu'as tu dans le panneau de gestion des cartes son ?

vois tu ta carte ?

6. Le samedi, mai 8 2010, 13:31 par jojo

Salut,

J'ai la même carte, au démarrage, elle fonctionne, mais au retour d'une mise en veille, je n'ai plus de son... Pourtant dans envy24, je vois la jauge du digital mixer qui s'agite, mais il n'y a aucun son audible.

ça marche chez toi, la mise en veille ?

7. Le mercredi, mai 19 2010, 15:59 par fx

Bonjour,
Même problème que toi: plus de son après une mise en veille (fc11).
Je m'en sort avec les cdes suivantes:

$ pulseaudio --kill
$ pulseaudio --start

8. Le dimanche, mai 23 2010, 18:22 par jojo

Merci, j'ai essayé ces commandes, j'ai aussi tenté : sudo alsa force-reload
Mais aucune de ces commandes ne donnent de résultat...

Pourtant le Vu-metre du master de envy24 control bouge, mais pas de son...

Comprends pas