Utiliser des plugins 32 bits sur un firefox 64bits

Tous les linuxiens ayant un linux AMD64 s’est déjà confronté à ce problème: comment mettre des plugins 32 bits dans un firefox 64bis. Il y a bien la méthode du chroot qui est très lourde ou une autre qui est de mettre un firefox 32bits , mais on est pas mal bloqué.

Il semble qu’il existe une alternative: nspluginwrapper. Voici comment je l’ai installé sur ubuntu edgy. Je pense ré editer l’expérience avec debian etch.

Je me suis basé sur un post du forum d’ubuntu qui est mieux que le tutoriel présent sur ce même site. Installer les paquets suivants:

Puis executer les commandes suivantes

Recupérer le package i386 de flash-plugin-nonfree et executer la commande suivante:


Enfin installer le wrapper du plugin flash 32 bits dans firefox 64 bits

Enfin, vérifier que le plugin est bien actif, démarrer firefox et aller sur la page about:plugins A ce moment, le son ne doit pas fonctionner avec flash, pour corriger, il faut suivre le tutoriel d’ubuntu

Sauf peut-être le son Il reste maintenant à activer le son pour les animations flash. Pour cela, il faut d’abord installer le paquet lib32asound2.

Ensuite il faut modifier le fichier /etc/firefox/firefoxrc :

Cherchez la ligne FIREFOX_DSP="none" et changez la par FIREFOX_DSP="aoss". maintenant il ne doit plus y avoir de problème!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *